larger smaller normal text version of this page
Vertalingen: en

phplist Documentatie

Systeemvereisten voor phpList.


phpList wordt vooral ontwikkeld met met de volgende systeemconfiguratie in het achterhoofd, heowel het ook op andere systemen kan draaien:
  • GNU / Linux Server
  • Apache Webserver
  • PHP versie 4.3.x (or higher)/(IMAP module vereist voor verwerken van bounces (terukerende mail))
  • Mysql database server (versie 3.23 of hoger)

phpList draait ook op Windows, met Apache, PHP en MySQL. We raden aan om een XAMPP server op Windows te draaien om phplist te testen en ontwikkelen.

En phpList draait op PHP 5, MySQL 5 ook, de ontwikkelaars gebruiken PHP 5.1.6 en Mysql 5.0.27.

Gebruikers hebben ook gemeld dat phpList aangepast kan worden coor gebruik met Microsoft IIS web server. Dit is momenteel niet ondersteund, maar u kunt hier meer informatie over vinden via de volgende link: phpList IIS of door de forums te doorzoeken. Het is waarschijnlijk dat phpList draait op oudere versies van PHP, maar het is niet aangeraden.

het is aangeraden om IMAP ondersteuning aan uw PHP installatie toe te voegen. Om phplist toe te staan automatisch bounces te verwerken is dit vereist.

phpList maakt nu ook gebruik van ADOdb wat het ook op andere database-servers dan MySQL kan laten draaien, maar dit is niet getest door de ontwikkelaars, en we hebben er ook nog niet veel meldingen over ontvangen.

Als MTA (Mail Transfer Agent) gebruiken de ontwikkelaars Qmail, maar er zou geen MTA afhankelijkheid mogen zijn voor phpList, gezien het zenden van mail via PHP op uw systeem werkt.


PHP safe mode


Het is hoogst aangeraden om phpList met "safe mode" in PHP uit, te draaien. We hebben alles gedaan wat we konden om het in safe mode te laten werken, maar wanneer je bij systemen komt met meer dan 500 gebruikers, dan is het waarschijnlijk dat er problemen voorkomen. Ook werkt het automatisch verwerken van bounces NIET in safe mode.



Basis phpList Concepten
phpList Documentatie
Page was generated in 0.0533 seconds